Новое поколение .Net будет адекватно работать на Linux?

Малакасофт снова жрёт всё что видит, но в этот раз - ИМО, но новость приятная:

https://vk.com/wall-33241_522652

Я много наслышан о кривоте mono (хотя у самого Linux никогда не стоял). Но на сколько я понимаю - эта новость значит что с .Net5 - можно будет запускать .Net приложения на Linux на столько же стабильно как на винде.

В связи с этим вопрос к разработчикам: будете ли вы делать какую то опциональную поддержку компиляции под .Net5? И если да, ожидать ли её когда .Net5 выйдет, или через некоторое время?

Насколько я понимаю, с какого-то момента останется только .NET 5.0. И если там будет обратная совместимость, то просто проект соберётся под .NET 5.0.

Да, но это ведь будет только через несколько лет после выхода .Net5.0 .

Мы не генерируем код под .NET Core - там достаточно много отличий. Думаю, если в .NET 5 под Linux будет такая же проблема, то мы не сможем это сделать.

1 симпатия